Applies to:
Siebel eConfigurator - Version 7.7.2.2 [18356] to 8.1.1.3[21219] [Release V7 to V8]All Platforms
Product Release: V7 (Enterprise)
Version: 7.7.2.2 [18356]
Database: Oracle 9.2.0.6
Application Server OS: Sun Solaris 9
Database Server OS: IBM AIX 5L 5.2
This document was previously published as Siebel SR 38-2641330411.
Checked for relevance on 23-Nov-2010
Symptoms
Customer deployed remote eConfigurator functionality in their production environment. Here users sometimes receive following error message:(rmodel.cpp (2460)) SBL-SVC-00203: Not connected to server
When users attempted to configure order again, then all seems to be working. Before and after this error message user properly connects to Configuration server.
Cause
Change Request #10504967 was created to address error "SBL-SVC-00203, Not connected to server". The description of this change request is "Random failures of accessing remote eConfigurator with DeltaQuote". It can happen when DeltaQuote is invoked on a timed out remote connection, for instance from a previous DeltaQuote.The error could be reproduced with following scenario:
1) Check what is currently set for eProdCfgKeepAliveTime on AOM
2) Setup simple testcase:
Create a BS in the application (Administration - Business Service) with following code:
function Service_PreInvokeMethod (MethodName, Inputs, Outputs)
{
var s = TheApplication().GetService("Configurator Service");
var inp = TheApplication().NewPropertySet();
var out = TheApplication().NewPropertySet();
inp.SetProperty("Product Id","dummy");
s.InvokeMethod("DeltaQuote",inp,out);
return (CancelOperation);
}
The first run will create a new remote eCfg session which will return a session specific cookie. It will also show an error message from DeltaQuote because of missing input parameters. Please ignore the error as we only use DeltaQuote for reproducing problem with remote session.
3) Wait for eProdCfgKeepAliveTime --> remote eCfg session is timed out
4) Call upper script again and you get following error message: Not connected to the server. (SBL-SVC-00203)
70*SBL-SMI-00107: Internal: The context for the given task was not found.1*013*smimtpool.cpp3*8490*0*0*0*
63*SBL-SMI-00216: Internal: Not an error, all the threads are busy1*012*smiworkq.cpp4*15770*0*0*0*
70*SBL-SMI-00107: Internal: The context for the given task was not found.1*013*smimtpool.cpp4*10330*0*0*0*
5) Call it again at once. Error disappears and a new session is started. Behavior is as in 2) described
Solution
As a workaround please increase parameter eProdCfgKeepAliveTime on AOM. This will not remove the error but it will happen more rarely. If the error happens please repeat your last action. This should be successful as well.Please note: If you change eProdCfgKeepAliveTime on AOM then ConnIdleTime on remote eConfigurator OM should be greater than eProdCfgKeepAliveTime (i.e. eProdCfgKeepAliveTime+1).
Defect is fixed in following Siebel versions:
8.0
7.7.2.4QF
7.7.2.7FP
7.8.2.5FP
7.7.2.6QF
7.8.2.4QF
8.1.1.9FP
8.1.1.4QF
pplies to:
Siebel eConfigurator - Version 7.7.1 SIA [18306] and laterInformation in this document applies to any platform.
Symptoms
Cause
Solution
You can specify how long product configurator sessions remain active by setting the server parameter for Keep Alive Time. This parameter specifies the time in seconds that a session can remain idle before the session is timed out. The default value of -1 means that the session can remain idle indefinitely and will not be timed out.
Parameter Name: eProdCfgKeepAliveTime
Display Name: Product Configurator - Keep Alive Time of Idle Session
Data Type: Integer
Default Value: -1
Description: The amount of time in seconds that a configuration session can remain inactive before the session is killed.
1. eCommunications Object Manager (ENU)
The eConfigurator session is timing out after around 45 minutes as expected.
Applies to:
Siebel eConfigurator - Version 7.8.2.10 SIA [19241] to 7.8.2.10 SIA [19241] [Release V7]Information in this document applies to any platform.
***Checked for relevance on 27-Jun-2012***
Symptoms
Customer reports a component crash when pushing button Explanation within eConfiguratorCause
This issue is a defect in 7.8.2.10 web client.
Repro steps:
Create a root product with 2 child items:
root
|------a
|------b
1) write a rule: a requires b
2) Validate product
3) select a --> b is selected automatically
4) remove b --> you get an error page with buttons Undo, Proceed, Explanation
5) click on Explanation button
--> the underlying object manager process crashes.
Following error messages can possibly be seen in the logfile:
SBL-SCB-00011
SBL-SSM-00006
SBL-SVC-00203
Following business service/method is called:
Configurator Session Service, GetDetailedReqExpl
Callstack of the crash:
IloExtractable::getImpl()
IloModel::getImpl()
IloConfiguration::getImpl()
IloConfiguration::getCatalog()
IlogConfigRequestManager::getPortFromPath
IlogConfigRequestManager::reinterpretFailedRequest
IlogConfigRequestManager::generateFailureExplanation
IlogConfigRequestManager::getFailedRequestExplanationIterator(bool cheapXpl=false)
ConfiguratorWorker::getFailedRequestExplanationIterator(bool cheapXpl=false)
CSSCxSession::GetDetailedReqExpl
CSSCxSessionMgr::GetDetailedReqExpl
CSSCxObjInstService::GetDetailedReqExpl
Root cause:
Issue does not occur in V8 or 7.8.2.8 and earlier. It is the result of some code changes in 7.8.2.10.